Hola.
Me he comprado un mBot 2.4 G para utilizarlo con mis alumnos. En clase tenemos equipos muy básicos equipados con Windows Xp porque no no pueden con W7.
He verificado que con W7 puedo enviar vía USB los programas con "uploap to arduino" pero cuando utilizo Xp me da un error de compilación.
Si no lo soluciono tendré que comprar otro tipo de robot y es una pena.

_Arduino:1
.6.5 (Windows XP), Placa:"Arduino/Genuino Uno"

collect2.exe: error: ld returned 5 exit status
Error de compilación

This report would have more information with
"Show verbose output during compilation"
activala desde Archivo > Preferencias

Hola. Me he comprado un mBot 2.4 G para utilizarlo con mis alumnos. En clase tenemos equipos muy básicos equipados con Windows Xp porque no no pueden con W7. He verificado que con W7 puedo enviar vía USB los programas con "uploap to arduino" pero cuando utilizo Xp me da un error de compilación. Si no lo soluciono tendré que comprar otro tipo de robot y es una pena. _ _Arduino:1_.6.5 (Windows XP), Placa:"Arduino/Genuino Uno" collect2.exe: error: ld returned 5 exit status Error de compilación This report would have more information with "Show verbose output during compilation" activala desde Archivo > Preferencias_ _
editado 13 Nov '16 a las 7:02 pm

El problema viene de la versión de Arduino que incluye el mBlock, es de las más recientes y el archivo ld.exe de esta versión no es compatible con XP

Solución:

Tan simple como localizar el archivo ld.exe dentro de la carpeta de instalación de mBlock

mBlock\Arduino\hardware\tools\avr\avr\bin

y sustituirlo por el de una versión de Arduino compatible con XP por ejemplo la 1.0.6.
Lo he subido a dropbox para que te resulte más fácil:

https://www.dropbox.com/s/mkx3uwf4wi4j0r8/ld.exe?dl=1

El problema viene de la versión de Arduino que incluye el mBlock, es de las más recientes y el **archivo ld.exe** de esta versión no es compatible con XP ### Solución: Tan simple como localizar el archivo ld.exe dentro de la carpeta de instalación de mBlock > mBlock\Arduino\hardware\tools\avr\avr\bin y sustituirlo por el de una versión de Arduino compatible con XP por ejemplo la 1.0.6. Lo he subido a dropbox para que te resulte más fácil: > https://www.dropbox.com/s/mkx3uwf4wi4j0r8/ld.exe?dl=1

hola,
pues a mi no me ha funcionado... tengo el mismo problema: el robot funciona bien conectardo al ordenador pero no puedo subirle programas pq da error de compilación.
al canviar el Id.exe por la version q decis, al clicar upload to arduino, no se muestra el boton de enviar de la subpantalla de la derecha, entre "back" y "Editar con IDE Arduino".
las funciones de actualizar firmware y restaurar programa predeterminado van bien

en otro ordenador con linux me pasa lo mismo, error al compilar.

gracias!

hola, pues a mi no me ha funcionado... tengo el mismo problema: el robot funciona bien conectardo al ordenador pero no puedo subirle programas pq da error de compilación. al canviar el Id.exe por la version q decis, al clicar upload to arduino, no se muestra el boton de enviar de la subpantalla de la derecha, entre "back" y "Editar con IDE Arduino". las funciones de actualizar firmware y restaurar programa predeterminado van bien en otro ordenador con linux me pasa lo mismo, error al compilar. gracias!

hola,
pues a mi no me ha funcionado... tengo el mismo problema: el robot funciona bien conectardo al ordenador pero no puedo subirle programas pq da error de compilación.
al canviar el Id.exe por la version q decis, al clicar upload to arduino, no se muestra el boton de enviar de la subpantalla de la derecha, entre "back" y "Editar con IDE Arduino".
las funciones de actualizar firmware y restaurar programa predeterminado van bien

en otro ordenador con linux me pasa lo mismo, error al compilar.

gracias!

En el código que intentas subir ¿ Tienes el bloque de mBot Program ?

>hola, >pues a mi no me ha funcionado... tengo el mismo problema: el robot funciona bien conectardo al ordenador pero no puedo subirle programas pq da error de compilación. >al canviar el Id.exe por la version q decis, al clicar upload to arduino, no se muestra el boton de enviar de la subpantalla de la derecha, entre "back" y "Editar con IDE Arduino". >las funciones de actualizar firmware y restaurar programa predeterminado van bien >en otro ordenador con linux me pasa lo mismo, error al compilar. >gracias! En el código que intentas subir ¿ Tienes el bloque de **mBot Program** ?

uy, perdón, no se ha funcionado el avisador.

pues si, están los bloques mbot, y sale el círculo verde de conectado, y las funciones se ejecutan en el robot. de hecho, al clicar con el boton derecho sobre el programa, sí q sale la opción de upload to arduino58810cfc0c37f.jpg
lo he probado en un windows vista y tampoco, ahí me da el error de compilar. no ha valido poner el id.exe antiguo. cuando da error, la luz verde q indica conexión se vuelve roja, y lo tengo q volver a conectar manualmente.

gracias!

uy, perdón, no se ha funcionado el avisador. pues si, están los bloques mbot, y sale el círculo verde de conectado, y las funciones se ejecutan en el robot. de hecho, al clicar con el boton derecho sobre el programa, sí q sale la opción de upload to arduino![58810cfc0c37f.jpg](serve/attachment&path=58810cfc0c37f.jpg) lo he probado en un windows vista y tampoco, ahí me da el error de compilar. no ha valido poner el id.exe antiguo. cuando da error, la luz verde q indica conexión se vuelve roja, y lo tengo q volver a conectar manualmente. gracias!
editado 19 Jan '17 a las 7:04 pm

hola?
estoy a la espera de respuesta. no tengo manera de subir el programa al robot ni con windows xp ni vista, necesito ayuda, por favor. gracias.

hola? estoy a la espera de respuesta. no tengo manera de subir el programa al robot ni con windows xp ni vista, necesito ayuda, por favor. gracias.

Me pasa lo mismo , en W8 sin problema , en WXP no me va, no hice de momento el cambio que decís ya que acabo de ver entrar ahora al foro por primera vez, espero a ver si hay solución y sino cuando tenga tiempo probaré lo dicho a ver si a mí me va y os lo comento....

Me pasa lo mismo , en W8 sin problema , en WXP no me va, no hice de momento el cambio que decís ya que acabo de ver entrar ahora al foro por primera vez, espero a ver si hay solución y sino cuando tenga tiempo probaré lo dicho a ver si a mí me va y os lo comento....

pues nada, no hay respuesta. pero no os esforceis. he probado la version de linux y funciona correctamente, ya no necesito la versión xp.

pues nada, no hay respuesta. pero no os esforceis. he probado la version de linux y funciona correctamente, ya no necesito la versión xp.

He efectuado los cambios que comentas y ya va con mi querido XP.

Gracias.

He efectuado los cambios que comentas y ya va con mi querido XP. Gracias.

Hola Antonio. A mi me pasa lo mismo con Linux.
Como lo arreglaste ?
gracias

Hola Antonio. A mi me pasa lo mismo con Linux. Como lo arreglaste ? gracias
1.52k
vistas
10
respuestas
5
seguidores
vista previa (en vivo)
introduzca al menos un 10 caracteres
Advertencia: Mencionaste a %MENTIONS%, pero ellos no pueden ver el mensaje y no serán notificados
Guardando...
Guardado
Todos los posteos de este tema serán borrados ?
Borrador pendiente ... Click para continuar editando
Descartar borrador