Hola,

Tengo una placa Arduino Uno conectada con un Me Uno Shield (https://www.makeblock.es/productos/arduino_uno_shield/)

y un Pack Mini ventilador (https://www.makeblock.es/productos/mini_ventilador/)

Conectando directamente el mini ventilador al puerto 3 de la Uno Shield, sin haber cargado ningún programa, se pone en marcha el motor. ¿Eso no es normal, no?

Por otro lado, he visto que en Mblock 3.4.11 para la placa ME Uno Shield no tiene el bloque de "Set Mini Fan" que tiene la Placa Orion.

Estoy intentado crear el bloque copiando el bloque runfan de orion.s2e a shield.s2e pero creo que me falta la equivalencia entre puertos y pines de la UnoShield.
En la Orion veo:

    var portToPin = {
        Port3: [12, 13],
        Port4: [8, 2],
        Port5: [1, 0],
        Port6: [16, 17]
    };

Y en la uno shield debería definir :

    var portToPin = {
        Port3: [?, ?],
        Port7: [?, ?],
        Port8: [?, ?]
    };

No sé qué números de pin se corresponde con cada puerto. He supuesto que debo utilizar los puertos azules 3,7,8, ya que el ventilador tiene rj25 azul.

Espero alguien me pueda orientar un poco.

Gracias

Hola, Tengo una placa Arduino Uno conectada con un Me Uno Shield (https://www.makeblock.es/productos/arduino_uno_shield/) y un Pack Mini ventilador (https://www.makeblock.es/productos/mini_ventilador/) Conectando directamente el mini ventilador al puerto 3 de la Uno Shield, sin haber cargado ningún programa, se pone en marcha el motor. ¿Eso no es normal, no? Por otro lado, he visto que en Mblock 3.4.11 para la placa ME Uno Shield no tiene el bloque de "Set Mini Fan" que tiene la Placa Orion. Estoy intentado crear el bloque copiando el bloque runfan de orion.s2e a shield.s2e pero creo que me falta la equivalencia entre puertos y pines de la UnoShield. En la Orion veo: var portToPin = { Port3: [12, 13], Port4: [8, 2], Port5: [1, 0], Port6: [16, 17] }; Y en la uno shield debería definir : var portToPin = { Port3: [?, ?], Port7: [?, ?], Port8: [?, ?] }; No sé qué números de pin se corresponde con cada puerto. He supuesto que debo utilizar los puertos azules 3,7,8, ya que el ventilador tiene rj25 azul. Espero alguien me pueda orientar un poco. Gracias
17
vistas
0
respuestas
1
seguidores
vista previa (en vivo)
introduzca al menos un 10 caracteres
Advertencia: Mencionaste a %MENTIONS%, pero ellos no pueden ver el mensaje y no serán notificados
Guardando...
Guardado
Todos los posteos de este tema serán borrados ?
Borrador pendiente ... Click para continuar editando
Descartar borrador